SOURCECODEBD.NET

Live Experience

which IP block will go through which ISP -

>Specify which IP block will go through which IIG

-> Use route-map for tuning the outgoing traffic
 
Router A Configuration
 
!
interface GigabitEthernet0/1
 description Main LAN
 (ip and other config)......
 ip policy route-map uplink
!
router bgp 130
network 10.10.10.0 mask 255.255.224.0
network 10.10.20.0 mask 255.255.240.0
neighbor 100.100.100.1 remote-as 600
neighbor 200.200.200.1 remote-as 500
neighbor 100.100.100.1 prefix-list firstblock out
neighbor 200.200.200.1 prefix-list secondblock out
!
ip prefix-list firstblock permit 10.10.10.0/24
 
!
ip prefix-list secondblock permit 10.10.20.0/24
 
!
ip access-list 1 permit 10.10.10.0 0.0.0.255
!
route-map uplink permit 10
match ip address 1
set default next-hop 100.100.100.1  [10.10.10.0/24 Ip block will go through 100.100.100.1]
route-map uplink permit 20
You are here: Home / BGP / BGP WHICH IP BLOCK WILL GO THROUGH WHICH ISP