SOURCECODEBD.NET

Live Experience

BGP with Multi-hop (load-balancing)

BGP WITH MULTI-HOP (LOAD-BALANCING)
 
[Customer Cisco Router]
 
Current configuration:
!
 
!
hostname Customer
!
interface Loopback0
description to Loopback for BGP 
ip address 2.2.2.2 255.255.255.255 
 
!
interface FastEthernet1/0
description to Internal network 
ip address 192.168.100.1 255.255.255.0 
 
!
interface Serial0/0 
description to ISP - WAN 1
ip address 100.100.100.1 255.255.255.252 
no fair-queue
 
!
interface Serial0/1
description to ISP - WAN 2
ip address 200.200.200.1 255.255.255.252
no fair-queue
 
!
router bgp 100
no auto-summary
network 192.168.100.0 mask 255.255.255.0
neighbor 3.3.3.3 remote-as 200
neighbor 3.3.3.3 version 4
neighbor 3.3.3.3 ebgp-multihop 2
neighbor 3.3.3.3 update-source loopback0
neighbor 3.3.3.3 prefix-list 1 out
!
ip classless 
ip route 3.3.3.3 255.255.255.255 Serial0
ip route 3.3.3.3 255.255.255.255 Serial1
!
ip prefix-list 1 description to ISP
ip prefix-list 1 seq 5 permit 192.168.100.0/24 le 32
!
line con 0
line aux 0
line vty 0 4
login
!
end 
 
 
 
[ISP Cisco Router]
 
Current configuration:
!
 
!
hostname ISP
!
interface Loopback0
description to Loopback for BGP 
ip address 3.3.3.3 255.255.255.255 
 
!
interface Serial0/0 
description to WAN 1 
ip address 100.100.100.2 255.255.255.252 
no fair-queue
 
!
interface Serial0/1
description to WAN 2
ip address 200.200.200.2 255.255.255.252
no fair-queue
 
!
router bgp 200
no auto-summary
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 version 4
neighbor 2.2.2.2 ebgp-multihop 2
neighbor 2.2.2.2 update-source loopback0
neighbor 2.2.2.2 default-originate <---to send a default route
 
!
ip classless 
ip route 1.1.1.1 255.255.255.255 Serial0
ip route 1.1.1.1 255.255.255.255 Serial1
!
line con 0
line aux 0
line vty 0 4
login
!
end
 
Verify The BGP Output
 
Customer# show ip bgp neighbors 3.3.3.3 ad
ISP#show ip bgp nei 1.1.1.1 ro
Customer#show ip bgp neighbors 3.3.3.3 ro
You are here: Home / BGP / BGP WITH MULTI-HOP (LOAD-BALANCING)