SOURCECODEBD.NET

Live Experience

Single BGP with Default Route

SINGLE BGP WITH DEFAULT ROUTE
 
[Customer Cisco Router]
 
Current configuration:
!
hostname Customer
 
!
interface FastEthernet0/1
description to LAN 
ip address 192.168.100.1 255.255.255.0 
 
!
interface Serial0/1
description to ISP 
ip address 100.100.100.1 255.255.255.252 
no fair-queue
 
!
router bgp 100
no auto-summary
network 192.168.100.0 mask 255.255.255.0
neighbor 100.100.100.2 remote-as 200 <---[ISP's ASN]
neighbor 100.100.100.2 version 4
neighbor 100.100.100.2 prefix-list 1 out
!
ip classless 
!
ip prefix-list 1 description announcing routes to ISP
ip prefix-list 1 seq 5 permit 192.168.100.0/24 le 32
!
 
!
end
 
 
[ISP Cisco Router]
 
Current configuration:
!
hostname ISP
!
interface Serial0/1 
description to ISP 
ip address 100.100.100.2 255.255.255.252 
no fair-queue
!
 
router bgp 200
neighbor 100.100.100.1 remote-as 100 <---[Other side's ASN]
neighbor 100.100.100.1 version 4
neighbor 100.100.100.1 default-originate <----[Send default route to customer through BGP]
neighbor 100.100.100.1 prefix-list 2 in
!
ip classless 
!
ip prefix-list 2 description from customer or peer
ip prefix-list 2 seq 5 permit 192.168.100.0/24 le 32 <----[Accepting This Block of IP]
!
 
!
end
 
 
To verify the Ouput
 
Customer# show ip bgp neighbors 100.100.100.2
Customer# show ip bgp nei 100.100.100.2
ISP# show ip bgp nei 100.100.100.1
You are here: Home / BGP / SINGLE BGP WITH DEFAULT ROUTE