SOURCECODEBD.NET

Live Experience

Single BGP with Multi-hop

SINGLE BGP WITH MULTI-HOP
 
[Customer Cisco Router]
 
 
Current configuration:
!
 
!
hostname Customer
!
interface FastEthernet1/0
description to Internal network 
ip address 192.168.100.1 255.255.255.0 
 
!
interface Serial0/1 
description to ISP 
ip address 100.100.100.1 255.255.255.252 
no fair-queue
!
 
interface Loopback 0
ip address 2.2.2.2 255.255.255.255 
!
 
router bgp 100
no auto-summary
network 192.168.100.0 mask 255.255.255.0
neighbor 3.3.3.3 remote-as 20 <----[ISP's ASN]
neighbor 3.3.3.3 version 4
neighbor 3.3.3.3 ebgp-multihop 2
neighbor 3.3.3.3 update-source loopback0
!
ip classless 
 
ip route 3.3.3.3 255.255.255.255 100.100.100.2 
!
 
!
end
 
 
 
[ISP Cisco Router]
 
 
Current configuration:
!
 
!
hostname ISP
!
!
 
interface Serial0/1 
description to ISP 
ip address 100.100.100.2 255.255.255.252 
no fair-queue
 
!
interface Loopback 0
ip address 3.3.3.3 255.255.255.255 
!
 
router bgp 20
neighbor 2.2.2.2 remote-as 10 <----[Customer's ASN]
neighbor 2.2.2.2 version 4
neighbor 2.2.2.2 default-originate <----[Send default route to customer through BGP]
neighbor 2.2.2.2 ebgp-multihop 2
neighbor 2.2.2.2 update-source loopback0
neighbor 2.2.2.2 prefix-list 2 in
!
 
ip classless 
!
ip route 2.2.2.2 255.255.255.255 100.100.100.1 
!
ip prefix-list 2 description from customer or peer
ip prefix-list 2 seq 5 permit 10.1.0.0/24 le 32 <----[Accepting Only this block of IP]
!
 
!
end
 
 
To Verify the Output
 
Customer# show ip bgp neighbors 3.3.3.3
Customer#show ip bgp neighbors 3.3.3.3 
ISP#show ip bgp neighbors 2.2.2.2
You are here: Home / BGP / SINGLE BGP WITH MULTI-HOP